Supportanteckning 124906
E-post
Fel: Det gick inte att ansluta till PunchOut-katalog
Problem

Jag får följande felmeddelande när jag försöker öppna en leverantörs PunchOut-katalog:

Det gick inte att ansluta till PunchOut-katalog. Kontakta din systemadministratör om problemet kvarstår.

Lösning

Se till att:

  1. Leverantörens ANID har konfigurerats korrekt i leverantörens Ariba Procurement-lösning och
  2. Leverantören skickar varugruppskoddata i PunchOutOrderMessage (POOM). 

Alla PunchOutSetupResponse-dokument som skickas till Ariba Network måste innehålla statuskod 200 och URL till startsidan. Avvikelser från detta innebär ett ogiltigt cXML-svar.

Följande exempel ger ett korrekt cXML-svar:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

Granska PunchOut-cXML-dokumentationen tillsammans med IT- eller utvecklingsavdelningen och se till att din applikation uppfyller kraven för att denna funktion ska fungera korrekt.

Orsak

Felet inkluderar upprättandet av en initial anslutning till leverantörens PunchOut-webbplats.

Några vanliga orsaker till detta felmeddelande är:

Ytterligare information

Mer information om PunchOut-webbplatsplanering finns i cXML-lösningsguiden.


Gäller för

SAP Ariba Catalog
SAP Business Network

Användningsvillkor  |  Copyright  |  Säkerhetsinformation  |  Sekretess