Информация от службы поддержки 124906
Электронная почта
Ошибка: Не удалось подключиться к каталогу PunchOut
Проблема

При попытке доступа к каталогу PunchOut поставшика выводится следующее сообщение об ошибке:

Не удалось подключиться к каталогу PunchOut. Если проблема сохраняется, обратитесь за помощью к системному администратору

Решение

Обеспечьте следующее:

  1. ANID поставщика правильно настроен в решении Ariba Procurement покупателя, а
  2. поставщик отправляет данные о коде товара или услуги в PunchOutOrderMessage (POOM). 

Все документы PunchOutSetupResponse, отправляемые в Ariba Network, должны содержать код состояния 200 и URL-адрес StartPage. При любом отклонении от этих условий ответ cXML недопустим.

Пример правильного ответа cXML:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

Поработайте со своей группой ИТ или разработок, чтобы проверить cXML-документацию PunchOut и обеспечить соответствие приложения требованиям, выполнение которых необходимо для правильной работы этой функции.

Причина

Эта ошибка затрагивает начальное соединение с сайтом PunchOut поставщика.

Ниже перечислены распространенные причины вывода этого сообщения об ошибке.

Дополнительная информация

Узнайте подробнее о планировании сайта PunchOut в Руководстве по решениям cXML.


Применимо к

SAP Ariba Catalog
SAP Business Network

Условия использования  |  Авторские права  |  Безопасность  |  Конфиденциальность