Nota de suporte 124906
E-mail
Erro: Não foi possível estabelecer a conexão com o catálogo PunchOut
Problema

Recebo a seguinte mensagem de erro quando tento acessar um catálogo PunchOut do fornecedor:

Não foi possível estabelecer a conexão com o catálogo PunchOut. Se o problema persistir, entre em contato com o administrador de sistema para obter assistência.

Resolução

Certifique-se de que:

  1. O ANID do fornecedor está configurado corretamente na solução de compras da Ariba do comprador e
  2. O fornecedor está enviando dados do código de mercadoria no PunchOutOrderMessage (POOM). 

Todos os documentos PunchOutSetupResponse enviados para o Ariba Network devem conter um código de status 200 e o Uniform Resource Locater (URL) de StartPage . Qualquer diferença constitui uma resposta cXML inválida.

O exemplo a seguir fornece uma resposta cXML correta:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

Trabalhe com sua equipe de TI ou de desenvolvimento para revisar a documentação cXML PunchOut e para assegurar que o seu aplicativo cumpre os requisitos para este recurso funcionar corretamente.

Causa

O erro implica estabelecer uma conexão inicial com o site PunchOut do fornecedor.

Alguns motivos comuns para esta mensagem de erro:

Informações adicionais

Saiba mais sobre o Planejamento do site PunchOut no Guia de Soluções cXML.


Aplicável a

SAP Ariba Catalog
SAP Business Network

Termos de uso  |  Copyright  |  Divulgação de segurança  |  Privacidade