Notatka dot. wsparcia 124906
E-mail
Błąd: Nie można połączyć się z katalogiem PunchOut
Problem

Podczas próby dostępu do katalogu PunchOut dostawcy pojawia się następujący komunikat o błędzie:

Niemożliwe połączenie z katalogiem PunchOut. Jeśli problem będzie się powtarzał, skontaktuj się z administratorem systemu, aby uzyskać pomoc.

Rozwiązanie

Upewnij się, że:

  1. identyfikator ANID dostawcy jest odpowiednio skonfigurowany w rozwiązaniu zakupowym Ariba nabywcy oraz
  2. dostawca wysyła dane kodu towaru w PunchOutOrderMessage (POOM). 

Wszystkie dokumenty PunchOutSetupResponse wysłane do Ariba Network muszą zawierać kod statusu 200 i StartPage Uniform Resource Locator (URL). Wszelkie odchylenia w tym zakresie powodują nieprawidłową odpowiedź cXML.

Poniższy przykład stanowi poprawną odpowiedź cXML:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

Współpracuj z zespołem IT lub zespołem programistów, aby przejrzeć dokumentację PunchOut cXML i upewnić się, że Twoja aplikacja spełnia wymagania dla poprawnego działania tej funkcji.

Przyczyna

Błąd wynika z ustanowienia początkowego połączenia z serwisem PunchOut dostawcy.

Oto kilka typowych powodów pojawienia się tego komunikatu o błędzie:

Informacje dodatkowe

Dowiedz się więcej o Planowaniu serwisu PunchOut w Przewodniku po rozwiązaniach cXML.


Zastosowanie

SAP Ariba Catalog
SAP Business Network

Warunki użytkowania  |  Prawa autorskie  |  Ujawnianie informacji o zabezpieczeniach  |  Prywatność