サポートノート 124906
電子メール
エラー: パンチアウトカタログに接続できませんでした
問題

サプライヤのパンチアウトカタログにアクセスしようとしたときに以下のエラーメッセージが表示されました。

パンチアウトカタログに接続できませんでした。問題が解決しない場合は、システム管理者に問い合わせてください。

解決策

確認事項:

  1. サプライヤの ANID がバイヤーの Ariba Procurement ソリューションで適切に設定されており、
  2. サプライヤが商品分類コードデータを PunchOutOrderMessage (POOM) で送信している。 

Ariba Network に送信されるすべての PunchOutSetupResponse ドキュメントには、200 状況コードと StartPage URL (Uniform Resource Locater) が含まれている必要があります。これ以外の場合は無効な cXML 応答が構成されます。

正しい cXML 応答の例を以下に示します。

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

IT または開発チームとともにパンチアウト cXML ドキュメントを確認し、この機能が正常に機能するための要件をアプリケーションが満たしていることを確認します。

原因

このエラーは、サプライヤのパンチアウトサイトと最初の接続を確立することに関係します。

このエラーメッセージの一般的な理由のいくつかを以下に示します。

追加情報

パンチアウトサイト計画の詳細については、『cXML ソリューションガイド』を参照してください。


該当項目

SAP Ariba Catalog
SAP Business Network

使用条件  |  Copyright  |  セキュリティに関する情報  |  情報の保護