Nota di supporto 124906
Posta elettronica
Errore: Impossibile connettersi al catalogo PunchOut
Problema

Quando tento di accedere al catalogo PunchOut di un fornitore, ricevo il seguente messaggio di errore:

Impossibile connettersi al catalogo PunchOut. Se il problema persiste, contattare l'amministratore del sistema per richiedere assistenza.

Soluzione

Assicurarsi che:

  1. l'ANID del fornitore sia configurato correttamente nella soluzione Ariba Procurement del compratore e
  2. il fornitore stia inviando i dati del codice prodotto nel PunchOutOrderMessage (POOM). 

Tutti i documenti PunchOutSetupResponse inviati ad Ariba Network devono contenere il codice stato 200 e l'URL (Uniform Resource Locator) StartPage. Qualsiasi altro assetto determina un messaggio di risposta cXML non valido.

Di seguito è indicato un esempio di messaggio di risposta cXML corretto:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

Collaborare con il proprio team di sviluppo o IT per esaminare la documentazione relativa al cXML per il PunchOut e verificare che la propria applicazione soddisfi i requisiti per il corretto funzionamento di questa funzionalità.

Causa

L’errore si verifica quando si tenta di stabilire una connessione iniziale con il sito PunchOut del fornitore.

Alcuni motivi comuni all’origine di questo messaggio di errore sono i seguenti:

Ulteriori informazioni

Maggiori informazioni sulla pianificazione del sito di PunchOut nella Guida alle soluzioni cXML.


Si applica a

SAP Ariba Catalog
SAP Business Network

Condizioni di utilizzo  |  Copyright  |  Informazioni sulla sicurezza  |  Privacy