Note d'assistance 124906
E-mail
Erreur : Connexion au catalogue PunchOut impossible.
Problème

J'obtiens le message d'erreur suivant lorsque je tente d'accéder au catalogue PunchOut d'un fournisseur :

Connexion au catalogue PunchOut impossible. Si le problème persiste, contactez l'administrateur système pour obtenir de l'aide.

Résolution

Vérifiez les points suivants :

  1. L'ID AN du fournisseur est correctement configuré dans la solution d'approvisionnement Ariba de l'acheteur, et
  2. Le fournisseur envoie des données de code de famille d'achat dans le message PunchOutOrderMessage (POOM). 

Tous les documents PunchOutSetupResponse envoyés à Ariba Network doivent contenir un code de statut 200 et l'URL (Uniform Resource Locater) StartPage. Toute dérogation entraîne une réponse cXML non valide.

L'exemple ci-dessous illustre une réponse cXML valide :

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

Avec votre équipe informatique ou de développement, passez en revue la documentation cXML PunchOut et vérifiez que votre application remplit bien les conditions pour que cette fonctionnalité agisse correctement.

Cause

L'erreur provient d'un problème de connexion initiale avec le site PunchOut du fournisseur.

Voici quelques unes des raisons courantes pouvant être à l'origine de ce message d'erreur :

Informations supplémentaires

En savoir plus sur la planification de sites PunchOut dans le guide des solutions cXML.


S'applique à

SAP Ariba Catalog
SAP Business Network

Conditions d'utilisation  |  Copyright  |  Informations sur la sécurité  |  Confidentialité