Nota de asistencia técnica 124906
Correo electrónico
Error: No es posible conectarse con el catálogo de PunchOut
Problema

He recibido el siguiente mensaje de error al intentar acceder al catálogo de PunchOut de un proveedor:

No es posible conectarse con el catálogo de PunchOut. Si el problema persiste, pida ayuda al administrador del sistema.

Resolución

Asegúrese de que:

  1. el ANID del proveedor se ha configurado correctamente en la solución de compras de Ariba del comprador y de que
  2. el proveedor está enviando los datos del código de mercancías en el PunchOutOrderMessage (POOM). 

Todos los documentos de PunchOutSetupResponse enviados a Ariba Network deben contener un código de estado 200 y el localizador de recursos uniforme (URL) de StartPage. Cualquier desviación de esto constituye una respuesta cXML no válida.

El siguiente ejemplo proporciona una respuesta cXML correcta:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

Trabaje con su equipo de TI o de desarrollo para revisar la documentación de cXML de PunchOut y para garantizar que su aplicación cumple los requisitos para que esta característica funcione correctamente.

Motivo

El error se da al establecer una conexión inicial con el sitio de PunchOut del proveedor.

Los motivos más comunes para este error son los siguientes:

Información adicional

Obtenga más información sobre la planificación del sitio de PunchOut en la Guía de soluciones cXML.


Se aplica a

SAP Ariba Catalog
SAP Business Network

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad