Support Note KB0392744
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Error: Unable to connect to PunchOut Catalog
Symptom

I receive the following error message when attempting to access a supplier's punchout catalog:

Unable to connect to PunchOut Catalog. If problem persists, ask your system administrator for assistance.


Environment

SAP Ariba Catalogs


Cause

The error involves establishing an initial connection with the supplier's PunchOut site.

A few common reasons for this error message are the following:


Resolution

Ensure that:

  1. The supplier's ANID is configured appropriately within the buyer's Ariba Procurement Solution, and
  2. The supplier is sending commodity code data in the PunchOutOrderMessage (POOM).

All PunchOutSetupResponse documents sent to the SAP Business Network must contain a 200 status code and the StartPage Uniform Resource Locater (URL). Any deviation from this constitutes an invalid cXML response.

The following example provides a correct cXML response:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
<Response>
<Status code = "200" text = "success"/>
<PunchOutSetupResponse>
<StartPage>
<URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
</StartPage>
</PunchOutSetupResponse>
</Response>

Work with your IT or development team to review the PunchOut cXML documentation and to ensure that your application fulfills the requirements for this feature to work correctly.


See Also

Learn more about SAP Help Portal: PunchOut site planning in the cXML Solutions Guide.



Applies To

Catalog Management > Punchout Catalog
SAP Business Network for Procurement & Supply Chain > Catalogs

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