Support Note KB0392532
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Cannot cancel a Purchase Requisition (PR) or Purchase Order (PO)
Symptom

I do not see the Cancel button on a Purchase Requisition (PR) or Purchase Order (PO).

I see the Cancel button on a PR or PO, but I get an error message when I click it.

I cannot cancel a PR or PO.


Cause

You cannot cancel a PO if any of the following apply:

Similarly, you cannot cancel a PR if any of the conditions above are met for any of the associated POs.


Resolution

If the PO is an ERP order, have your Designated Support Contact (DSC) confirm with SAP Support if the parameter Application.Procure.UseCancelOrderIntegration is enabled.

If the PO has not been ordered yet, reject the applicable PR or use the integration task Import Purchase Order Status to import an error, as applicable.

If any of the following apply:

You cannot cancel the PO. Simply close the PO to move forward, and either communicate with the supplier externally (outside of SAP solutions) to inform them that the order should not be fulfilled, or send a message to the supplier from the PO directly, if your site has supplier messaging enabled.

Next, ensure that the customer-editable parameter Application.Procure.AllowChangeRequisition is set to Yes.

Then, ensure that your user is in the Purchasing Manager group or one of its descendant (child, grandchild, etc.) groups, such as Procurement Manager.

If the PO has any Invoice history present or Invoices associated with it (irrespective if the Invoices are rejected, reconciled or canceled), the Cancel button will not be visible on the order. The Invoice history is maintained for future reference only - therefore the inability to cancel the PO is expected. To proceed, you can reject or force-reject Invoice Reconciliation (IR) documents raised against a PO and issue a credit memo, then Close the PO for All Actions and include any relevant comments.

If the PO is closed for changes or all actions, reopen the PO, and try canceling the PO again.

If the PO is in one of the following statuses:

Ensure that the PO has no net received amount (you can create negative receipts to adjust the received amounts), and update the appropriate parameter(s). Then, try canceling the PO again.

If there is an Advance Payment (APMT) in Paying or Paid status associated with the PO, set the self-service parameter Application.Purchasing.HideCancelButtonForAdvancedPaymentInPayingOrPaidStatus to Yes, and try canceling the PO again.

If you are trying to cancel a PR, check the settings above against all associated POs. If any of the POs associated with the PR cannot be canceled, then you cannot cancel the PR either.

If you need further assistance, contact SAP Support.



Applies To

Purchasing
Purchasing > Purchase Orders
Purchasing > Requisitioning

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